Oracle Exadata Patching GI Version Compatibility Requirement

There are two main questions we need to answer while planning your Exadata patching.

  1. What are the software versions that are compatible with the Exadata Database Machine Hardware version?
  2. What are the minimum Oracle Grid Infrastructure and Database software releases that are certified with Exadata Storage Server Software?

I’ll answer the above questions with the below scenario.

Scenario

  • Current Exadata, GI, and Databases version and releases.
Exadata Database Machine Hardware X6
Exadata Storage Server Software 18.1.6.0.0.180529
Oracle Grid Infrastructure release 18.2.0.0.180417
Oracle Databases releases 12.1.0.2.180417, 12.2.0.1.180417

 

The objective is to patch Exadata components to the latest Exadata software release (July 2021 QFSDP as of writing this blog).   

  • New Exadata, GI, and databases version and releases.
Exadata Storage Server Software 21.2.2.0.0.210720
Oracle Grid Infrastructure release 19.12.0.0.210720
Oracle Databases releases 12.1.0.2.210720, 12.2.0.1.210720

 

1. What are the software versions that are compatible with the Exadata Database Machine Hardware version?

We can find the answer to that question in MOS Doc ID 888828.1. The Doc has a table that lists the software versions that are compatible with each supported Exadata Database Machine Hardware version.

exadata database machine

version compatibility and requirements

The table above shows that X6 can run Exadata software 12.1.2.3.1 and higher. That means the latest Exadata Software (21.2.2.0.0) is supported on X6 Hardware.

2. What are the minimum Oracle Grid Infrastructure and Database Software releases that are certified with Exadata Storage Server Software?

Exadata software Supplemental Note answers this question.

Exadata software (21.2.2.0.0) Supplemental Note 2781458.1 lists the minimum Oracle Grid Infrastructure and Database Software releases supported by Exadata software 21.2.2.0.0.

exadata storage server

exadata 21

exadata release update

The current GI release is 18.2.0.0.180417 and based on information from Supplemental Note 2781458.1 above, the minimum supported GI release is 18.7.0.0.190716.

The current GI release (18.2.0.0.180417) < the minimum supported GI release (18.7.0.0.190716).

The current DB releases (12.1.0.2.180417, 12.2.0.1.180417) < the minimum supported DB releases (12.1.0.2.180831, 12.2.0.1.181016).

So, it is mandatory to patch GI from 18.2 to 18.7 or the latest 18c GIRU and DB 12.1 and 12.2 homes to the minimum supported releases or the latest 12.1/12.2 RU before we can patch compute and cell nodes.  

Note: we can NOT upgrade GI from 18c to 19c before patching compute and cell nodes to Exadata software 19, 20, or 21.

As a result, the patching and upgrade plan will be as following:

  1. Patch GI from 2to the latest 18c GIRU.
  2. Patch DB homes 1/12.2to the latest 12.1/12.2 RU.
  3. Patch cell nodes and compute nodes directly from 1.6to 21.2.2.
  4. Patch IB switches.
  5. Upgrade GI from 18c to 19c (optional but highly recommended).

 

My next blog will be on upgrading GI from 18c to 19c on Exadata.

Stay tuned!

Share on:
Come work with the Best